Vanity Address Generation

I want to try generating some vanity addresses for G1. I found this project

and tried the easy regex, « ^ba »; however, I can’t import any of them into Cesium. I took salt to mean the identifier and password to mean password. I get an entirely different public key from Cesium when I try pasting them in. I also tried switching them around just in case, but I still get different keys.

2 « J'aime »

Hi @test,
thanks for your interest in vanitygen.

I have just tried the tool again and didn’t have any trouble making it work. Here is an example:

"^ba" "batgR2LquSAhfu7P7isv6NesvSb4wvgpmrFTD5fPA7T" ")k!(Z4B621IApH9xEfl," "1Tr*1SvKA,dHoH&d"

In this particular instance, “1Tr*1SvKA,dHoH&d” is the “secret identifier” and “)k!(Z4B621IApH9xEfl,” is the “password”. When I copy those (without the surrounding quotes of course) in cesium, I do get back the key “batgR2LquSAhfu7P7isv6NesvSb4wvgpmrFTD5fPA7T”.

Just in case, what is your environment (processor, operating system, compiler…)?

1 « J'aime »

I ran:

$ ./vanitygen -w ./search/words.txt -n 6 10 -c ./search/easy.txt
Reading file ./search/words.txt for words...
Read 703 bytes.
Test B58PK successful
Reading file ./search/easy.txt...
1 regex found
Searching for "^ba"

and yeah. I omitted the quotes as well. I’ll send you my system specs.

2 « J'aime »

Well done to @test for finding a bug. It is now fixed. :slight_smile:

2 « J'aime »

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.